# Mautic allows users enumeration due to weak password login

Advisory record · `GHSA-8vff-35qm-qjvv`

- **Identifiers:** `GHSA-8vff-35qm-qjvv` · `CVE-2024-47059` · `PKSA-vtdm-dnf3-m5wp`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-204](https://cwe.mitre.org/data/definitions/204.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-204](https://agentprime.io/advisories/tag/cwe-204.md)
- **Published:** 18 Sept 2024
- **Updated:** 19 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Sept 2024, 22:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mautic/core` (Packagist): affected `>=5.1.0, <5.1.1`; fixed in `5.1.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mautic (mautic/core) versions 5.1.0 before 5.1.1 are vulnerable to username enumeration through the login page. When a valid username is submitted with a weak password, the application reports that the password is too weak, but an invalid username with a weak password returns "Invalid credentials," letting an attacker tell which usernames exist. Upgrade to mautic/core 5.1.1 or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (Mautic)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8vff-35qm-qjvv)

## Sources

- [GitHub Advisory Database: GHSA-8vff-35qm-qjvv](https://github.com/advisories/GHSA-8vff-35qm-qjvv)
- [OSV: GHSA-8vff-35qm-qjvv](https://osv.dev/vulnerability/GHSA-8vff-35qm-qjvv)
- <https://github.com/mautic/mautic/security/advisories/GHSA-8vff-35qm-qjvv>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-47059>
- <https://github.com/mautic/mautic>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8vff-35qm-qjvv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8vff-35qm-qjvv/>. Everything for agents: <https://agentprime.io/llms.txt>.
