# Spring Boot's default security filter chain has no authorization rule with Actuator but without Health

Advisory record · `GHSA-8v8j-3hxp-93wr`

- **Identifiers:** `GHSA-8v8j-3hxp-93wr` · `CVE-2026-40976`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-305](https://cwe.mitre.org/data/definitions/305.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 28 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Apr 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.springframework.boot:spring-boot` (Maven): affected `>=4.0.0, <4.0.6`; fixed in `4.0.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Spring Boot (org.springframework.boot:spring-boot is the affected package, but the name here is just "Spring Boot"), versions 4.0.0 through 4.0.5, has a default web security filter chain that can be ineffective, allowing unauthenticated access to all endpoints. Exploitation requires a servlet-based application with no Spring Security configuration of its own that depends on spring-boot-actuator-autoconfigure but not on spring-boot-health. Upgrade to Spring Boot 4.0.6 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (vmware)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0049, the 42nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8v8j-3hxp-93wr)

## Sources

- [GitHub Advisory Database: GHSA-8v8j-3hxp-93wr](https://github.com/advisories/GHSA-8v8j-3hxp-93wr)
- [OSV: GHSA-8v8j-3hxp-93wr](https://osv.dev/vulnerability/GHSA-8v8j-3hxp-93wr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40976>
- <https://github.com/spring-projects/spring-boot>
- <https://spring.io/security/cve-2026-40976>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8v8j-3hxp-93wr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8v8j-3hxp-93wr/>. Everything for agents: <https://agentprime.io/llms.txt>.
