# Incorrect Comparison in cvxopt

Advisory record · `GHSA-8rh6-h94m-vj54`

- **Identifiers:** `GHSA-8rh6-h94m-vj54` · `CVE-2021-41500` · `PYSEC-2021-870`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-697](https://cwe.mitre.org/data/definitions/697.html)
- **Tags:** [CWE-697](https://agentprime.io/advisories/tag/cwe-697.md)
- **Published:** 7 Jan 2022
- **Updated:** 13 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Jan 2022, 00:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `cvxopt` (PyPI): affected `<1.2.7`; fixed in `1.2.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 68th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 7 Jan 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-8rh6-h94m-vj54](https://github.com/advisories/GHSA-8rh6-h94m-vj54)
- [OSV: GHSA-8rh6-h94m-vj54](https://osv.dev/vulnerability/GHSA-8rh6-h94m-vj54)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-41500>
- <https://github.com/cvxopt/cvxopt/issues/193>
- <https://github.com/cvxopt/cvxopt/commit/d5a21cf1da62e4269176384b1ff62edac5579f94>
- <https://github.com/advisories/GHSA-8rh6-h94m-vj54>
- <https://github.com/cvxopt/cvxopt>
- <https://github.com/pypa/advisory-database/tree/main/vulns/cvxopt/PYSEC-2021-870.yaml>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CXTPM3DGVYTYQ54OFCMXZVWVOMR7JM2D>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8rh6-h94m-vj54>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8rh6-h94m-vj54/>. Everything for agents: <https://agentprime.io/llms.txt>.
