# Pterodactyl's improper JWT scoping allows subuser to upload files when not explicitly granted \`file.create\` permissions

Advisory record · `GHSA-8r6w-3qq5-4p4r`

- **Identifiers:** `GHSA-8r6w-3qq5-4p4r` · `CVE-2026-54593` · `GO-2026-6120` · `PKSA-hhbv-vvdq-cchz`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1259](https://cwe.mitre.org/data/definitions/1259.html) · [CWE-1270](https://cwe.mitre.org/data/definitions/1270.html)
- **Tags:** [CWE-1259](https://agentprime.io/advisories/tag/cwe-1259.md) · [CWE-1270](https://agentprime.io/advisories/tag/cwe-1270.md)
- **Published:** 28 Jul 2026
- **Updated:** 18 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Jul 2026, 15:43 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pterodactyl/panel` (Packagist): affected `<1.12.3`; fixed in `1.12.3`
- `github.com/pterodactyl/wings` (Go): affected `<1.12.2`; fixed in `1.12.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Pterodactyl Panel (Packagist pterodactyl/panel) before 1.12.3 and the Wings daemon (Go github.com/pterodactyl/wings) before 1.12.2 are affected. A subuser who has any server access, such as console connection or file or backup download, can reuse a panel-issued JWT meant for those actions to upload arbitrary files to the same server without the file.create permission. Upgrade the Panel to 1.12.3 and Wings to 1.12.2 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0068, the 52nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8r6w-3qq5-4p4r)

## Sources

- [GitHub Advisory Database: GHSA-8r6w-3qq5-4p4r](https://github.com/advisories/GHSA-8r6w-3qq5-4p4r)
- [OSV: GHSA-8r6w-3qq5-4p4r](https://osv.dev/vulnerability/GHSA-8r6w-3qq5-4p4r)
- <https://github.com/pterodactyl/panel/security/advisories/GHSA-8r6w-3qq5-4p4r>
- <https://github.com/pterodactyl/panel/pull/5636>
- <https://github.com/pterodactyl/panel/commit/7ffcd636310bb72b54bac3280d2a15e727feded7>
- <https://github.com/pterodactyl/wings/commit/d0ddc80844479302abdaf9654de3bacd511c0f5c>
- <https://github.com/pterodactyl/panel>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8r6w-3qq5-4p4r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8r6w-3qq5-4p4r/>. Everything for agents: <https://agentprime.io/llms.txt>.
