# Caddy has an RFC 7230 §6.1 compliance issue / Hop-by-hop headers that leak through

Advisory record · `GHSA-8qx7-j2v2-x6q5`

- **Identifiers:** `GHSA-8qx7-j2v2-x6q5` · `CVE-2026-55458` · `GO-2026-6874`
- **State:** Confirmed
- **Severity:** CVSS 2.9 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 28 Oct 2026
- **Updated:** 5 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 19:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/caddyserver/caddy/v2` (Go): affected `<2.11.5`; fixed in `2.11.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Caddy's reverse proxy, in the github.com/caddyserver/caddy/v2 Go module before 2.11.5, does not strip hop-by-hop headers (such as Alt-Svc, Keep-Alive, Proxy-Authenticate, Transfer-Encoding, and Trailer) from upstream responses to WebSocket upgrade requests. An attacker who controls or compromises an upstream server could make these headers reach clients, such as Set-Cookie for cookie injection or Alt-Svc for connection hijacking. Upgrade to version 2.11.5 or later, which contains the fix.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.9 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8qx7-j2v2-x6q5)
- 5 Nov 2026, 20:15 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-55458)
- 5 Nov 2026, 21:18 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-55458)

## Sources

- [GitHub Advisory Database: GHSA-8qx7-j2v2-x6q5](https://github.com/advisories/GHSA-8qx7-j2v2-x6q5)
- [OSV: GHSA-8qx7-j2v2-x6q5](https://osv.dev/vulnerability/GHSA-8qx7-j2v2-x6q5)
- <https://github.com/caddyserver/caddy/security/advisories/GHSA-8qx7-j2v2-x6q5>
- <https://github.com/caddyserver/caddy>
- <https://github.com/caddyserver/caddy/releases/tag/v2.11.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8qx7-j2v2-x6q5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8qx7-j2v2-x6q5/>. Everything for agents: <https://agentprime.io/llms.txt>.
