# Upgrading doesn't prevent exploiting vulnerable XWiki documents

Advisory record · `GHSA-8q9q-r9v2-644m`

- **Identifiers:** `GHSA-8q9q-r9v2-644m` · `CVE-2023-36468`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-459](https://cwe.mitre.org/data/definitions/459.html)
- **Tags:** [CWE-459](https://agentprime.io/advisories/tag/cwe-459.md)
- **Published:** 30 Jun 2023
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Jun 2023, 20:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.xwiki.platform:xwiki-platform-oldcore` (Maven): affected `>=2.0, <14.10.7 || >=15.0-rc-1, <15.2-rc-1`; fixed in `14.10.7`, `15.2-rc-1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of xwiki-platform-oldcore from 2.0 before 14.10.7, and from 15.0-rc-1 before 15.2-rc-1, are affected. After an upgrade, old document revisions that still contain a previously fixed vulnerability can be executed, so an attacker with view rights may be able to run code and affect the whole installation. Upgrade to 14.10.7 or 15.2-rc-1; the source does not give a workaround beyond manually deleting old revisions of affected documents, which it notes is hard to do completely.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.019, the 79th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:21 UTC: First seen by agentprime
- 31 Oct 2026, 14:21 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8q9q-r9v2-644m)

## Sources

- [GitHub Advisory Database: GHSA-8q9q-r9v2-644m](https://github.com/advisories/GHSA-8q9q-r9v2-644m)
- [OSV: GHSA-8q9q-r9v2-644m](https://osv.dev/vulnerability/GHSA-8q9q-r9v2-644m)
- <https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-2g5c-228j-p52x>
- <https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-8q9q-r9v2-644m>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-36468>
- <https://github.com/xwiki/xwiki-platform/commit/15a6f845d8206b0ae97f37aa092ca43d4f9d6e59>
- <https://github.com/xwiki/xwiki-platform>
- <https://jira.xwiki.org/browse/XWIKI-20594>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8q9q-r9v2-644m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8q9q-r9v2-644m/>. Everything for agents: <https://agentprime.io/llms.txt>.
