# ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name

Advisory record · `GHSA-8mvw-22r7-w6fq`

- **Identifiers:** `GHSA-8mvw-22r7-w6fq` · `CVE-2013-0162`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-377](https://cwe.mitre.org/data/definitions/377.html)
- **Tags:** [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 5 May 2022
- **Updated:** 29 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2022, 02:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ruby_parser` (RubyGems): affected `>=2.0.2, <3.1.2`; fixed in `3.1.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 31st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 5 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-8mvw-22r7-w6fq](https://github.com/advisories/GHSA-8mvw-22r7-w6fq)
- [OSV: GHSA-8mvw-22r7-w6fq](https://osv.dev/vulnerability/GHSA-8mvw-22r7-w6fq)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-0162>
- <https://github.com/seattlerb/ruby_parser/commit/506c7e13cff6f8715385fa8488b621028b4ad280>
- <https://github.com/seattlerb/ruby_parser/commit/c35acd878d50a8e4ea35933e3fbdc493421d422c>
- <https://access.redhat.com/errata/RHSA-2013:0544>
- <https://access.redhat.com/errata/RHSA-2013:0582>
- <https://access.redhat.com/security/cve/CVE-2013-0162>
- <https://bugzilla.redhat.com/show_bug.cgi?id=892806>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby_parser/CVE-2013-0162.yml>
- <https://github.com/seattlerb/ruby_parser>
- <http://rhn.redhat.com/errata/RHSA-2013-0544.html>
- <http://rhn.redhat.com/errata/RHSA-2013-0548.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8mvw-22r7-w6fq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8mvw-22r7-w6fq/>. Everything for agents: <https://agentprime.io/llms.txt>.
