# YARD's default template vulnerable to Cross-site Scripting in generated frames.html

Advisory record · `GHSA-8mq4-9jjh-9xrc`

- **Identifiers:** `GHSA-8mq4-9jjh-9xrc` · `CVE-2024-27285`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 28 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Feb 2024, 18:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yard` (RubyGems): affected `<0.9.36`; fixed in `0.9.36`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 64th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8mq4-9jjh-9xrc)

## Sources

- [GitHub Advisory Database: GHSA-8mq4-9jjh-9xrc](https://github.com/advisories/GHSA-8mq4-9jjh-9xrc)
- [OSV: GHSA-8mq4-9jjh-9xrc](https://osv.dev/vulnerability/GHSA-8mq4-9jjh-9xrc)
- <https://github.com/lsegal/yard/security/advisories/GHSA-8mq4-9jjh-9xrc>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-27285>
- <https://github.com/lsegal/yard/pull/1538>
- <https://github.com/lsegal/yard/commit/1fcb2d8b316caf8779cfdcf910715e9ab583f0aa>
- <https://github.com/lsegal/yard/commit/2069e2bf08293bda2fcc78f7d0698af6354054be>
- <https://github.com/advisories/GHSA-8mq4-9jjh-9xrc>
- <https://github.com/lsegal/yard>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/yard/CVE-2024-27285.yml>
- <https://lists.debian.org/debian-lts-announce/2024/03/msg00006.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MR3Z2E2UIZZ7YOR7R645EVSBGWMB2RGA>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8mq4-9jjh-9xrc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8mq4-9jjh-9xrc/>. Everything for agents: <https://agentprime.io/llms.txt>.
