# Unsoundness in UTF-8 'String' trait

Advisory record · `GHSA-8mq4-3mwq-qvg6`

- **Identifiers:** `GHSA-8mq4-3mwq-qvg6` · `CVE-2026-92612` · `RUSTSEC-2026-0294`
- **State:** Confirmed
- **Severity:** CVSS 1.0 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-749](https://cwe.mitre.org/data/definitions/749.html)
- **Tags:** [CWE-749](https://agentprime.io/advisories/tag/cwe-749.md)
- **Published:** 18 Sept 2026
- **Updated:** 23 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Sept 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `iceoryx2-bb-container` (crates.io): affected `>=0.0.0-0, <0.10.0 || >=0.11.0-0`; fixed in `0.10.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The iceoryx2-bb-container crate, versions before 0.10.0 and the 0.11.0 pre-release range, exposes String contents as mutable bytes through safe APIs, and as_str() converts them to a Rust string slice without checking UTF-8. A caller using only safe Rust can build an invalid &str, which is undefined behavior. The source does not describe an attacker's required access level. The fix is to upgrade to version 0.10.0, which removes the mutable byte access methods as_mut_bytes and deref_mut.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 1.0 Low, CVSS 4.0: `CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0015, the 4th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0294)

## Sources

- [GitHub Advisory Database: GHSA-8mq4-3mwq-qvg6](https://github.com/advisories/GHSA-8mq4-3mwq-qvg6)
- [OSV: GHSA-8mq4-3mwq-qvg6](https://osv.dev/vulnerability/GHSA-8mq4-3mwq-qvg6)
- <https://crates.io/crates/iceoryx2-bb-container>
- <https://rustsec.org/advisories/RUSTSEC-2026-0294.html>
- <https://github.com/eclipse-iceoryx/iceoryx2/pull/1956>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8mq4-3mwq-qvg6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8mq4-3mwq-qvg6/>. Everything for agents: <https://agentprime.io/llms.txt>.
