# DeepSeek Harness contains an authentication bypass vulnerability in local HTTP control-plane API

Advisory record · `GHSA-8m2g-8cgm-3vcp`

- **Identifiers:** `GHSA-8m2g-8cgm-3vcp` · `CVE-2026-82533`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-807](https://cwe.mitre.org/data/definitions/807.html)
- **Tags:** [CWE-807](https://agentprime.io/advisories/tag/cwe-807.md)
- **Published:** 8 Sept 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Sept 2026, 18:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `@deepseek-ai/dsh-client-connection` (npm): affected `<0.1.2-alpha.1`; fixed in `0.1.2-alpha.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The npm package @deepseek-ai/dsh-client-connection, part of DeepSeek Harness, is affected before 0.1.2-alpha.1. Its local HTTP control-plane API validates only the client-supplied Host header rather than the actual connection origin, so an attacker can bypass authentication without a credential and gain full agent control, including privileged actions and access to stored conversations. Upgrade to 0.1.2-alpha.1 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 69th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8m2g-8cgm-3vcp)

## Sources

- [GitHub Advisory Database: GHSA-8m2g-8cgm-3vcp](https://github.com/advisories/GHSA-8m2g-8cgm-3vcp)
- [OSV: GHSA-8m2g-8cgm-3vcp](https://osv.dev/vulnerability/GHSA-8m2g-8cgm-3vcp)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-82533>
- <https://github.com/deepseek-ai/deepseek-harness/commit/3e24087bfaeabe40b58ba2f7b936895b8f93fe27>
- <https://github.com/deepseek-ai/deepseek-harness>
- <https://github.com/deepseek-ai/deepseek-harness/releases/tag/dsh-v0.1.2-alpha.1>
- <https://www.ox.security/blog/cve-2026-82533-deepseek-harness-ai-agent-sandbox-escape>
- <https://www.vulncheck.com/advisories/deepseek-harness-alpha-1-authentication-bypass-via-host-header-spoofing>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8m2g-8cgm-3vcp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8m2g-8cgm-3vcp/>. Everything for agents: <https://agentprime.io/llms.txt>.
