# Auth.js: Configuration errors can cause existence-based auth checks to fail open (auth object populated with an error)

Advisory record · `GHSA-8fpg-xm3f-6cx3`

- **Identifiers:** `GHSA-8fpg-xm3f-6cx3` · `CVE-2026-73421`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-285](https://cwe.mitre.org/data/definitions/285.html) · [CWE-636](https://cwe.mitre.org/data/definitions/636.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-636](https://agentprime.io/advisories/tag/cwe-636.md)
- **Published:** 23 Jul 2026
- **Updated:** 12 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Jul 2026, 14:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `next-auth` (npm): affected `>=5.0.0-beta.0, <5.0.0-beta.32`; fixed in `5.0.0-beta.32`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 23 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-8fpg-xm3f-6cx3](https://github.com/advisories/GHSA-8fpg-xm3f-6cx3)
- [OSV: GHSA-8fpg-xm3f-6cx3](https://osv.dev/vulnerability/GHSA-8fpg-xm3f-6cx3)
- <https://github.com/nextauthjs/next-auth/security/advisories/GHSA-8fpg-xm3f-6cx3>
- <https://github.com/nextauthjs/next-auth/commit/d008b9b764bf4b322a87e1822d1dda7789258d8f>
- <https://github.com/nextauthjs/next-auth>
- <https://github.com/nextauthjs/next-auth/releases/tag/next-auth@5.0.0-beta.32>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8fpg-xm3f-6cx3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8fpg-xm3f-6cx3/>. Everything for agents: <https://agentprime.io/llms.txt>.
