# Semaphore UI: CSRF vulnerability on password change endpoint - No CSRF token or password confirmation

Advisory record · `GHSA-8cj9-r88m-8945`

- **Identifiers:** `GHSA-8cj9-r88m-8945` · `CVE-2026-73292` · `GO-2026-6370`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-352](https://cwe.mitre.org/data/definitions/352.html) · [CWE-620](https://cwe.mitre.org/data/definitions/620.html)
- **Tags:** [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md) · [CWE-620](https://agentprime.io/advisories/tag/cwe-620.md)
- **Published:** 3 Sept 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Sept 2026, 19:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/semaphoreui/semaphore` (Go): affected `<0.0.0-20260707190631-c59c3dc9035b`; fixed in `0.0.0-20260707190631-c59c3dc9035b`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Semaphore UI (Go module github.com/semaphoreui/semaphore) is vulnerable to cross-site request forgery on its password change endpoint, affecting versions before 0.0.0-20260707190631-c59c3dc9035b. An attacker can host a malicious page that silently submits a password change for a user who is logged in, including an administrator, and then take over that account. The source reports the issue was tested on version 2.18.20. Upgrade to 0.0.0-20260707190631-c59c3dc9035b or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 14th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8cj9-r88m-8945)

## Sources

- [GitHub Advisory Database: GHSA-8cj9-r88m-8945](https://github.com/advisories/GHSA-8cj9-r88m-8945)
- [OSV: GHSA-8cj9-r88m-8945](https://osv.dev/vulnerability/GHSA-8cj9-r88m-8945)
- <https://github.com/semaphoreui/semaphore/security/advisories/GHSA-8cj9-r88m-8945>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-73292>
- <https://github.com/semaphoreui/semaphore/commit/2d6e2e3eb10e8bf688e2ab59609b909a012fad4c>
- <https://github.com/semaphoreui/semaphore/commit/c59c3dc9035badcbf0609c7d35679c06e590a956>
- <https://github.com/semaphoreui/semaphore>
- <https://github.com/semaphoreui/semaphore/releases/tag/v2.18.21>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8cj9-r88m-8945>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8cj9-r88m-8945/>. Everything for agents: <https://agentprime.io/llms.txt>.
