# TYPO3 CMS vulnerable to Denial of Service in Page Error Handling

Advisory record · `GHSA-8c28-5mp7-v24h`

- **Identifiers:** `GHSA-8c28-5mp7-v24h` · `BIT-typo3-2022-23500` · `CVE-2022-23500` · `PKSA-j3x1-dtrb-kbct` · `PKSA-wh51-qtyw-9mq5`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-405](https://cwe.mitre.org/data/definitions/405.html) · [CWE-674](https://cwe.mitre.org/data/definitions/674.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-405](https://agentprime.io/advisories/tag/cwe-405.md)
- **Published:** 13 Dec 2022
- **Updated:** 6 Dec 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Dec 2022, 17:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `typo3/cms-core` (Packagist): affected `>=9.0.0, <9.5.38 || >=10.0.0, <10.4.33 || >=11.0.0, <11.5.20`; fixed in `9.5.38`, `10.4.33`, `11.5.20`
- `typo3/cms` (Packagist): affected `>=10.0.0, <10.4.33 || >=11.0.0, <11.5.20`; fixed in `10.4.33`, `11.5.20`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> TYPO3 CMS packages typo3/cms-core (versions 9.0.0 to before 9.5.38, 10.0.0 to before 10.4.33, and 11.0.0 to before 11.5.20) and typo3/cms (versions 10.0.0 to before 10.4.33 and 11.0.0 to before 11.5.20) are affected. An attacker who can send HTTP requests for invalid or non-existing resources can trigger the page error handler to call the application recursively, which can exhaust the web server's limits and cause denial of service. Upgrade typo3/cms-core to 9.5.38, 10.4.33 or 11.5.20, and typo3/cms to 10.4.33 or 11.5.20.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0073, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:32 UTC: First seen by agentprime
- 31 Oct 2026, 14:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8c28-5mp7-v24h)

## Sources

- [GitHub Advisory Database: GHSA-8c28-5mp7-v24h](https://github.com/advisories/GHSA-8c28-5mp7-v24h)
- [OSV: GHSA-8c28-5mp7-v24h](https://osv.dev/vulnerability/GHSA-8c28-5mp7-v24h)
- <https://github.com/TYPO3/typo3/security/advisories/GHSA-8c28-5mp7-v24h>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-23500>
- <https://github.com/TYPO3/typo3/commit/1e5f44417f031c9c5a9f9d09a6a841cf89aa7b7a>
- <https://github.com/TYPO3/typo3/commit/73b46b6a627093112cfca4b895a198ca5e1970b7>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2022-23500.yaml>
- <https://github.com/TYPO3/typo3>
- <https://typo3.org/security/advisory/typo3-core-sa-2022-012>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8c28-5mp7-v24h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8c28-5mp7-v24h/>. Everything for agents: <https://agentprime.io/llms.txt>.
