# YesWiki: SQL injection via the \`recentchanges\` action \`period\` argument leads to arbitrary DB read

Advisory record · `GHSA-89v6-j5x6-cmj3`

- **Identifiers:** `GHSA-89v6-j5x6-cmj3` · `CVE-2026-52763` · `PKSA-qtt4-qmsv-g7gm`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-89](https://cwe.mitre.org/data/definitions/89.html) · [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [SQL injection](https://agentprime.io/advisories/tag/sql-injection.md) · [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Jul 2026, 20:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yeswiki/yeswiki` (Packagist): affected `<4.6.6`; fixed in `4.6.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> YesWiki versions before 4.6.6 (Packagist yeswiki/yeswiki) are affected by SQL injection through the period argument of the recentchanges action. An attacker who can save a page containing the action with a crafted period value can read arbitrary database content, and the leaked data appears in the page for any visitor; on default installs anonymous users may be able to save such a page. Upgrade to version 4.6.6 or later. The source gives no workaround.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-89v6-j5x6-cmj3)

## Sources

- [GitHub Advisory Database: GHSA-89v6-j5x6-cmj3](https://github.com/advisories/GHSA-89v6-j5x6-cmj3)
- [OSV: GHSA-89v6-j5x6-cmj3](https://osv.dev/vulnerability/GHSA-89v6-j5x6-cmj3)
- <https://github.com/YesWiki/yeswiki/security/advisories/GHSA-89v6-j5x6-cmj3>
- <https://github.com/YesWiki/yeswiki/commit/5da27474c3ee62270c8a6b9d7055d494cdbd38e5>
- <https://github.com/YesWiki/yeswiki>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-89v6-j5x6-cmj3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-89v6-j5x6-cmj3/>. Everything for agents: <https://agentprime.io/llms.txt>.
