# OpenZeppelin Contracts initializer reentrancy may lead to double initialization

Advisory record · `GHSA-88g8-f5mf-f5rj`

- **Identifiers:** `GHSA-88g8-f5mf-f5rj` · `CVE-2021-46320` · `CVE-2022-39384` · `GHSA-9c22-pwxw-p6hx`
- **State:** Confirmed
- **Severity:** CVSS 5.6 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-665](https://cwe.mitre.org/data/definitions/665.html)
- **Tags:** [CWE-665](https://agentprime.io/advisories/tag/cwe-665.md)
- **Published:** 14 Dec 2021
- **Updated:** 16 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Dec 2021, 21:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@openzeppelin/contracts` (npm): affected `>=3.2.0, <4.4.1`; fixed in `4.4.1`
- `@openzeppelin/contracts-upgradeable` (npm): affected `>=3.2.0, <4.4.1`; fixed in `4.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> OpenZeppelin Contracts and Contracts-Upgradeable from 3.2.0 before 4.4.1 are affected. An initializer function that runs separately from contract creation, such as in minimal proxies, can be re-entered if it makes an untrusted non-view external call, which can allow it to execute a second time. The source notes that upgradeable proxies are usually initialized during creation, where this is not feasible, so impact is believed to be minor. Upgrade both packages to 4.4.1 or later; until then, avoid untrusted external calls during initialization.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.6 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 68th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Dec 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-88g8-f5mf-f5rj](https://github.com/advisories/GHSA-88g8-f5mf-f5rj)
- [OSV: GHSA-88g8-f5mf-f5rj](https://osv.dev/vulnerability/GHSA-88g8-f5mf-f5rj)
- <https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9c22-pwxw-p6hx>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-39384>
- <https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3006>
- <https://github.com/OpenZeppelin/openzeppelin-contracts>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-88g8-f5mf-f5rj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-88g8-f5mf-f5rj/>. Everything for agents: <https://agentprime.io/llms.txt>.
