# discordrb OS Command Injection vulnerability

Advisory record · `GHSA-8832-4mm5-x2r6`

- **Identifiers:** `GHSA-8832-4mm5-x2r6` · `CVE-2023-28102`
- **State:** Confirmed
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-78](https://cwe.mitre.org/data/definitions/78.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md)
- **Published:** 14 Mar 2024
- **Updated:** 14 Mar 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Mar 2024, 20:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `discordrb` (RubyGems): affected `<3.4.3`; fixed in `3.4.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.026, the 85th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Mar 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-8832-4mm5-x2r6](https://github.com/advisories/GHSA-8832-4mm5-x2r6)
- [OSV: GHSA-8832-4mm5-x2r6](https://osv.dev/vulnerability/GHSA-8832-4mm5-x2r6)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-28102>
- <https://github.com/shardlab/discordrb/commit/91e13043ffa89227c3fcdc3408f06da237d28c95>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/discordrb/CVE-2023-28102.yml>
- <https://github.com/shardlab/discordrb>
- <https://securitylab.github.com/advisories>
- <https://securitylab.github.com/advisories/GHSL-2022-094_discordrb>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8832-4mm5-x2r6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8832-4mm5-x2r6/>. Everything for agents: <https://agentprime.io/llms.txt>.
