# Heap buffer overflow in \`UnsortedSegmentSum\` in TensorFlow

Advisory record · `GHSA-844w-j86r-4x2j`

- **Identifiers:** `GHSA-844w-j86r-4x2j` · `CVE-2019-16778` · `PYSEC-2019-209` · `PYSEC-2019-227` · `PYSEC-2019-234`
- **State:** Confirmed
- **Severity:** CVSS 2.6 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-122](https://cwe.mitre.org/data/definitions/122.html) · [CWE-681](https://cwe.mitre.org/data/definitions/681.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-681](https://agentprime.io/advisories/tag/cwe-681.md)
- **Published:** 16 Dec 2019
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Dec 2019, 20:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<1.15.0`; fixed in `1.15.0`
- `tensorflow-cpu` (PyPI): affected `<1.15.0`; fixed in `1.15.0`
- `tensorflow-gpu` (PyPI): affected `<1.15.0`; fixed in `1.15.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.6 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0079, the 56th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Dec 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-844w-j86r-4x2j](https://github.com/advisories/GHSA-844w-j86r-4x2j)
- [OSV: GHSA-844w-j86r-4x2j](https://osv.dev/vulnerability/GHSA-844w-j86r-4x2j)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-844w-j86r-4x2j>
- <https://nvd.nist.gov/vuln/detail/CVE-2019-16778>
- <https://github.com/tensorflow/tensorflow/commit/db4f9717c41bccc3ce10099ab61996b246099892>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-227.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-234.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-209.yaml>
- <https://github.com/tensorflow/tensorflow>
- <https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2019-002.md>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-844w-j86r-4x2j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-844w-j86r-4x2j/>. Everything for agents: <https://agentprime.io/llms.txt>.
