# Drupal Core has a rarely used feature, provided by an underlying library, which allows certain attributes of incoming HTTP requests to be overridden.

Advisory record · `GHSA-83v7-c2cf-p9c2`

- **Identifiers:** `GHSA-83v7-c2cf-p9c2` · `BIT-drupal-2025-13080` · `CVE-2025-13080` · `DRUPAL-CORE-2025-005` · `PKSA-bn52-vyzy-rmnm`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-754](https://cwe.mitre.org/data/definitions/754.html)
- **Tags:** [CWE-754](https://agentprime.io/advisories/tag/cwe-754.md)
- **Published:** 12 Nov 2025
- **Updated:** 10 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Nov 2025, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `drupal/core` (Packagist): affected `>=8.0.0, <10.4.9 || >=10.5.0, <10.5.6 || >=11.0.0, <11.1.9 || >=11.2.0, <11.2.8`; fixed in `10.4.9`, `10.5.6`, `11.1.9`, `11.2.8`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Nov 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-83v7-c2cf-p9c2](https://github.com/advisories/GHSA-83v7-c2cf-p9c2)
- [OSV: GHSA-83v7-c2cf-p9c2](https://osv.dev/vulnerability/GHSA-83v7-c2cf-p9c2)
- <https://www.drupal.org/sa-core-2025-005>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-83v7-c2cf-p9c2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-83v7-c2cf-p9c2/>. Everything for agents: <https://agentprime.io/llms.txt>.
