# React Server Components have multiple Denial of Service Vulnerabilities

Advisory record · `GHSA-83fc-fqcc-2hmg`

- **Identifiers:** `GHSA-83fc-fqcc-2hmg` · `CVE-2026-23864`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-1284](https://cwe.mitre.org/data/definitions/1284.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [CWE-1284](https://agentprime.io/advisories/tag/cwe-1284.md)
- **Published:** 29 Jan 2026
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Jan 2026, 15:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `react-server-dom-parcel` (npm): affected `>=19.0.0, <19.0.4 || >=19.1.0-canary-7130d0c6-20241212, <19.1.5 || >=19.2.0-canary-63779030-20250328, <19.2.4`; fixed in `19.0.4`, `19.1.5`, `19.2.4`
- `react-server-dom-turbopack` (npm): affected `>=19.1.0-canary-7130d0c6-20241212, <19.1.5 || >=19.0.0, <19.0.4 || >=19.2.0-canary-63779030-20250328, <19.2.4`; fixed in `19.1.5`, `19.0.4`, `19.2.4`
- `react-server-dom-webpack` (npm): affected `>=19.2.0-canary-63779030-20250328, <19.2.4 || >=19.1.0-canary-7130d0c6-20241212, <19.1.5 || >=19.0.0, <19.0.4`; fixed in `19.2.4`, `19.1.5`, `19.0.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.026, the 85th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 26 Jan 2026, 19:10 UTC: [Published by the maintainers as a GitHub repository advisory](https://github.com/react/react/security/advisories/GHSA-83fc-fqcc-2hmg)

## Sources

- [GitHub Advisory Database: GHSA-83fc-fqcc-2hmg](https://github.com/advisories/GHSA-83fc-fqcc-2hmg)
- [OSV: GHSA-83fc-fqcc-2hmg](https://osv.dev/vulnerability/GHSA-83fc-fqcc-2hmg)
- <https://github.com/facebook/react/security/advisories/GHSA-83fc-fqcc-2hmg>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-23864>
- <https://github.com/facebook/react>
- <https://react.dev/blog/2025/12/11/denial-of-service-and-source-code-exposure-in-react-server-components>
- <https://www.facebook.com/security/advisories/cve-2026-23864>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-83fc-fqcc-2hmg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-83fc-fqcc-2hmg/>. Everything for agents: <https://agentprime.io/llms.txt>.
