# Bref vulnerable to Body Parsing Inconsistency in Event-Driven Functions

Advisory record · `GHSA-82vx-mm6r-gg8w`

- **Identifiers:** `GHSA-82vx-mm6r-gg8w` · `CVE-2024-24754` · `PKSA-f29r-hw5p-d3rv`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 1 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Feb 2024, 22:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `bref/bref` (Packagist): affected `<2.1.13`; fixed in `2.1.13`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-82vx-mm6r-gg8w affects the bref/bref Composer package for versions before 2.1.13 when used with the Event-Driven Function runtime and a RequestHandlerInterface handler. Multipart request parts whose keys end with an open square bracket are parsed differently than in plain PHP, which may lead to application-dependent vulnerabilities or undefined behavior. The source suggests using PHP's parse_str to mimic plain PHP behavior, and the fix is in 2.1.13, so upgrading to 2.1.13 or later is the remedy.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:04 UTC: First seen by agentprime
- 31 Oct 2026, 14:04 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-82vx-mm6r-gg8w)

## Sources

- [GitHub Advisory Database: GHSA-82vx-mm6r-gg8w](https://github.com/advisories/GHSA-82vx-mm6r-gg8w)
- [OSV: GHSA-82vx-mm6r-gg8w](https://osv.dev/vulnerability/GHSA-82vx-mm6r-gg8w)
- <https://github.com/brefphp/bref/security/advisories/GHSA-82vx-mm6r-gg8w>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-24754>
- <https://github.com/brefphp/bref/commit/c77d9f5abf021f29fa96b5720b7b84adbd199092>
- <https://github.com/brefphp/bref>
- <https://github.com/brefphp/bref/blob/2.1.12/src/Event/Http/Psr7Bridge.php#L130-L168>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-82vx-mm6r-gg8w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-82vx-mm6r-gg8w/>. Everything for agents: <https://agentprime.io/llms.txt>.
