# Apache Syncope allows malicious administrators to inject Groovy code

Advisory record · `GHSA-825g-mm5v-ggq4`

- **Identifiers:** `GHSA-825g-mm5v-ggq4` · `CVE-2025-57738`
- **State:** Confirmed
- **Severity:** CVSS 7.2 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-653](https://cwe.mitre.org/data/definitions/653.html)
- **Tags:** [CWE-653](https://agentprime.io/advisories/tag/cwe-653.md)
- **Published:** 20 Oct 2025
- **Updated:** 5 Nov 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Oct 2025, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 7.2 (7.0 or more) and EPSS 0.23 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.syncope.core:syncope-core-spring` (Maven): affected `<3.0.14 || >=4.0.0-M0, <4.0.2`; fixed in `3.0.14`, `4.0.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.23, the 97th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:09 UTC: First seen by agentprime
- 31 Oct 2026, 15:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-825g-mm5v-ggq4)

## Sources

- [GitHub Advisory Database: GHSA-825g-mm5v-ggq4](https://github.com/advisories/GHSA-825g-mm5v-ggq4)
- [OSV: GHSA-825g-mm5v-ggq4](https://osv.dev/vulnerability/GHSA-825g-mm5v-ggq4)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-57738>
- <https://github.com/apache/syncope/commit/88c2b5b0be9e2ed66007d672e786165bc266e717>
- <https://github.com/apache/syncope/commit/8b08c4d5785599a0e38830dcff89738b93f02a16>
- <https://issues.apache.org/jira/browse/SYNCOPE-1907>
- <https://lists.apache.org/thread/x7cv6xv7z76y49grdr1hgj1pzw5zbby6>
- <https://syncope.apache.org/security#CVE-2025-57738>
- <http://github.com/apache/syncope>
- <http://www.openwall.com/lists/oss-security/2025/10/20/1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-825g-mm5v-ggq4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-825g-mm5v-ggq4/>. Everything for agents: <https://agentprime.io/llms.txt>.
