# Eclipse Dataspace Components's ConsumerPullTransferTokenValidationApiController doesn't check for token validit

Advisory record · `GHSA-8259-2x72-2gvc`

- **Identifiers:** `GHSA-8259-2x72-2gvc` · `CVE-2024-8642`
- **State:** Confirmed
- **Severity:** CVSS 5.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-303](https://cwe.mitre.org/data/definitions/303.html) · [CWE-305](https://cwe.mitre.org/data/definitions/305.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 11 Sept 2024
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Sept 2024, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.eclipse.edc:transfer-data-plane` (Maven): affected `>=0.5.0, <0.9.0`; fixed in `0.9.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.0 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/RE:L/U:Green`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:09 UTC: First seen by agentprime
- 31 Oct 2026, 15:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-8259-2x72-2gvc)

## Sources

- [GitHub Advisory Database: GHSA-8259-2x72-2gvc](https://github.com/advisories/GHSA-8259-2x72-2gvc)
- [OSV: GHSA-8259-2x72-2gvc](https://osv.dev/vulnerability/GHSA-8259-2x72-2gvc)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-8642>
- <https://github.com/eclipse-edc/Connector/commit/04899e91dcdb4a407db4eb7af3e7b6ff9a9e9ad6>
- <https://github.com/eclipse-edc/Connector>
- <https://github.com/eclipse-edc/Connector/blob/bcb2e42aee82ce1863be3dcbdab29919d39a0e97/extensions/control-plane/transfer/transfer-data-plane/src/main/java/org/eclipse/edc/connector/controlplane/transfer/dataplane/api/ConsumerPullTransferTokenValidationApiController.java>
- <https://github.com/eclipse-edc/Connector/releases/tag/v0.9.0>
- <https://gitlab.eclipse.org/security/cve-assignment/-/issues/28>
- <https://gitlab.eclipse.org/security/vulnerability-reports/-/issues/234>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-8259-2x72-2gvc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-8259-2x72-2gvc/>. Everything for agents: <https://agentprime.io/llms.txt>.
