# Jenkins REST APIs vulnerable to clickjacking

Advisory record · `GHSA-7xp8-7wqx-5hqx`

- **Identifiers:** `GHSA-7xp8-7wqx-5hqx` · `BIT-jenkins-2020-2105` · `CVE-2020-2105`
- **State:** Confirmed
- **Severity:** CVSS 3.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-1021](https://cwe.mitre.org/data/definitions/1021.html)
- **Tags:** [CWE-1021](https://agentprime.io/advisories/tag/cwe-1021.md)
- **Published:** 24 May 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 17:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.jenkins-ci.main:jenkins-core` (Maven): affected `<2.204.2 || >=2.205, <2.219`; fixed in `2.204.2`, `2.219`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.1 Low, CVSS 3.0: `CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 79th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-7xp8-7wqx-5hqx](https://github.com/advisories/GHSA-7xp8-7wqx-5hqx)
- [OSV: GHSA-7xp8-7wqx-5hqx](https://osv.dev/vulnerability/GHSA-7xp8-7wqx-5hqx)
- <https://nvd.nist.gov/vuln/detail/CVE-2020-2105>
- <https://github.com/jenkinsci/jenkins/commit/639ade55caa05324c60d15b2fa8df27ee0111b76>
- <https://access.redhat.com/errata/RHBA-2020:0402>
- <https://access.redhat.com/errata/RHBA-2020:0675>
- <https://access.redhat.com/errata/RHSA-2020:0681>
- <https://access.redhat.com/errata/RHSA-2020:0683>
- <https://github.com/jenkinsci/jenkins>
- <https://jenkins.io/security/advisory/2020-01-29/#SECURITY-1704>
- <http://www.openwall.com/lists/oss-security/2020/01/29/1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7xp8-7wqx-5hqx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7xp8-7wqx-5hqx/>. Everything for agents: <https://agentprime.io/llms.txt>.
