# FastMCP: Post-transform component authorization is skipped on direct calls

Advisory record · `GHSA-7xgj-8392-5q4r`

- **Identifiers:** `GHSA-7xgj-8392-5q4r`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 21:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fastmcp` (PyPI): affected `>=3.0.0, <3.4.10 || >=4.0.0, <4.1.2`; fixed in `3.4.10`, `4.1.2`
- `fastmcp-slim` (PyPI): affected `>=3.0.0, <3.4.10 || >=4.0.0, <4.1.2`; fixed in `3.4.10`, `4.1.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> FastMCP and fastmcp-slim versions 3.0.0 to before 3.4.10, and 4.0.0 to before 4.1.2, are affected. When a server transform changes a component's metadata, direct lookups return the transformed component without rechecking its authorization policy, so a client that knows the component identifier can invoke a tool or retrieve a resource or prompt that the policy denies. Upgrade to fastmcp or fastmcp-slim 3.4.10 or 4.1.2. Until then, avoid overlapping proxy templates for protected resources and enforce required authorization in the handler or at the server boundary.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7xgj-8392-5q4r)

## Sources

- [GitHub Advisory Database: GHSA-7xgj-8392-5q4r](https://github.com/advisories/GHSA-7xgj-8392-5q4r)
- [OSV: GHSA-7xgj-8392-5q4r](https://osv.dev/vulnerability/GHSA-7xgj-8392-5q4r)
- <https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-7xgj-8392-5q4r>
- <https://github.com/PrefectHQ/fastmcp/pull/5933>
- <https://github.com/PrefectHQ/fastmcp/pull/5934>
- <https://github.com/PrefectHQ/fastmcp/commit/85df42fbf2aa631cc81e0f986718b314128e91df>
- <https://github.com/PrefectHQ/fastmcp/commit/8649ba5fc91a68568a69729497edeb804a064332>
- <https://github.com/PrefectHQ/fastmcp>
- <https://github.com/PrefectHQ/fastmcp/releases/tag/v3.4.10>
- <https://github.com/PrefectHQ/fastmcp/releases/tag/v4.1.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7xgj-8392-5q4r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7xgj-8392-5q4r/>. Everything for agents: <https://agentprime.io/llms.txt>.
