# InventoryGui allows item duplication in GUIs which use GuiStorageElement

Advisory record · `GHSA-7whh-79j3-7c55`

- **Identifiers:** `GHSA-7whh-79j3-7c55` · `CVE-2025-62784`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-837](https://cwe.mitre.org/data/definitions/837.html)
- **Tags:** [CWE-837](https://agentprime.io/advisories/tag/cwe-837.md)
- **Published:** 28 Oct 2025
- **Updated:** 28 Oct 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2025, 17:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `de.themoep:inventorygui` (Maven): affected `<1.6.5`; fixed in `1.6.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:10 UTC: First seen by agentprime
- 31 Oct 2026, 15:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7whh-79j3-7c55)

## Sources

- [GitHub Advisory Database: GHSA-7whh-79j3-7c55](https://github.com/advisories/GHSA-7whh-79j3-7c55)
- [OSV: GHSA-7whh-79j3-7c55](https://osv.dev/vulnerability/GHSA-7whh-79j3-7c55)
- <https://github.com/Phoenix616/InventoryGui/security/advisories/GHSA-7whh-79j3-7c55>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-62784>
- <https://github.com/Phoenix616/InventoryGui/commit/690fc91d137c6cc04f6ed3a89449050964dd8cb9>
- <https://github.com/Phoenix616/InventoryGui>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7whh-79j3-7c55>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7whh-79j3-7c55/>. Everything for agents: <https://agentprime.io/llms.txt>.
