# Doorkeeper Improper Authentication vulnerability

Advisory record · `GHSA-7w2c-w47h-789w`

- **Identifiers:** `GHSA-7w2c-w47h-789w` · `CVE-2023-34246`
- **State:** Confirmed
- **Severity:** CVSS 4.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md)
- **Published:** 12 Jun 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Jun 2023, 19:50 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `doorkeeper` (RubyGems): affected `<5.6.6`; fixed in `5.6.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.2 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0072, the 53rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7w2c-w47h-789w)

## Sources

- [GitHub Advisory Database: GHSA-7w2c-w47h-789w](https://github.com/advisories/GHSA-7w2c-w47h-789w)
- [OSV: GHSA-7w2c-w47h-789w](https://osv.dev/vulnerability/GHSA-7w2c-w47h-789w)
- <https://github.com/doorkeeper-gem/doorkeeper/security/advisories/GHSA-7w2c-w47h-789w>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-34246>
- <https://github.com/doorkeeper-gem/doorkeeper/issues/1589>
- <https://github.com/doorkeeper-gem/doorkeeper/pull/1646>
- <https://github.com/doorkeeper-gem/doorkeeper>
- <https://github.com/doorkeeper-gem/doorkeeper/releases/tag/v5.6.6>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/doorkeeper/CVE-2023-34246.yml>
- <https://lists.debian.org/debian-lts-announce/2023/07/msg00016.html>
- <https://lists.debian.org/debian-lts-announce/2024/12/msg00010.html>
- <https://www.rfc-editor.org/rfc/rfc8252#section-8.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7w2c-w47h-789w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7w2c-w47h-789w/>. Everything for agents: <https://agentprime.io/llms.txt>.
