# Cross site scripting (XSS) in JupyterHub via Self-XSS leveraged by Cookie Tossing

Advisory record · `GHSA-7r3h-4ph8-w38g`

- **Identifiers:** `GHSA-7r3h-4ph8-w38g` · `BIT-jupyterhub-2024-28233` · `CVE-2024-28233` · `PYSEC-2026-1480`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-352](https://cwe.mitre.org/data/definitions/352.html) · [CWE-565](https://cwe.mitre.org/data/definitions/565.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md) · [CWE-565](https://agentprime.io/advisories/tag/cwe-565.md)
- **Published:** 28 Mar 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Mar 2024, 17:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jupyterhub` (PyPI): affected `<4.1.0`; fixed in `4.1.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> JupyterHub versions before 4.1.0 are affected. An attacker who tricks a user into visiting a malicious subdomain can use cookie tossing to trigger cross-site scripting that acts within the victim's session, potentially reaching the JupyterHub API and the user's single-user server. Upgrade to JupyterHub 4.1.0 or later, and enable domain-locked cookies by setting c.JupyterHub.cookie_host_prefix_enabled = True.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 26th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:36 UTC: First seen by agentprime
- 31 Oct 2026, 14:36 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7r3h-4ph8-w38g)

## Sources

- [GitHub Advisory Database: GHSA-7r3h-4ph8-w38g](https://github.com/advisories/GHSA-7r3h-4ph8-w38g)
- [OSV: GHSA-7r3h-4ph8-w38g](https://osv.dev/vulnerability/GHSA-7r3h-4ph8-w38g)
- <https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-7r3h-4ph8-w38g>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-28233>
- <https://github.com/jupyterhub/jupyterhub/commit/e2798a088f5ad45340fe79cdf1386198e664f77f>
- <https://github.com/jupyterhub/jupyterhub>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7r3h-4ph8-w38g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7r3h-4ph8-w38g/>. Everything for agents: <https://agentprime.io/llms.txt>.
