# Improper Input Validation in Apache Struts

Advisory record · `GHSA-7qwv-cwgj-c8rj`

- **Identifiers:** `GHSA-7qwv-cwgj-c8rj` · `CVE-2006-1547`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** Yes: KEV, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-749](https://cwe.mitre.org/data/definitions/749.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-749](https://agentprime.io/advisories/tag/cwe-749.md)
- **Published:** 1 May 2022
- **Updated:** 22 Oct 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 May 2022, 06:50 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- In CISA’s KEV catalogue since 21 Jan 2022: it is known to be exploited.
- CVSS score 7.5 (7.0 or more) and EPSS 0.55 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `struts:struts` (Maven): affected `<1.2.9`; fixed in `1.2.9`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:H`, from GitHub Advisory Database

- **CISA KEV:** Listed since 21 Jan 2022: known to be exploited.
- **EPSS:** 0.55, the 99th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:10 UTC: First seen by agentprime
- 31 Oct 2026, 15:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7qwv-cwgj-c8rj)

## Sources

- [GitHub Advisory Database: GHSA-7qwv-cwgj-c8rj](https://github.com/advisories/GHSA-7qwv-cwgj-c8rj)
- [OSV: GHSA-7qwv-cwgj-c8rj](https://osv.dev/vulnerability/GHSA-7qwv-cwgj-c8rj)
- <https://nvd.nist.gov/vuln/detail/CVE-2006-1547>
- <https://exchange.xforce.ibmcloud.com/vulnerabilities/25613>
- <https://github.com/apache/struts>
- <https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2006-1547>
- <http://issues.apache.org/bugzilla/show_bug.cgi?id=38534>
- <http://lists.suse.com/archive/suse-security-announce/2006-May/0004.html>
- <http://secunia.com/advisories/19493>
- <http://secunia.com/advisories/20117>
- <http://securitytracker.com/id?1015856>
- <http://struts.apache.org/struts-doc-1.2.9/userGuide/release-notes.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7qwv-cwgj-c8rj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7qwv-cwgj-c8rj/>. Everything for agents: <https://agentprime.io/llms.txt>.
