# Scrapy decompression bomb vulnerability

Advisory record · `GHSA-7j7m-v7m3-jqm7`

- **Identifiers:** `GHSA-7j7m-v7m3-jqm7` · `CVE-2024-3572` · `PYSEC-2026-1907`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 16 Feb 2024
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Feb 2024, 16:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `scrapy` (PyPI): affected `>=2.0.0, <2.11.1 || <1.8.4`; fixed in `2.11.1`, `1.8.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0081, the 57th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Feb 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-7j7m-v7m3-jqm7](https://github.com/advisories/GHSA-7j7m-v7m3-jqm7)
- [OSV: GHSA-7j7m-v7m3-jqm7](https://osv.dev/vulnerability/GHSA-7j7m-v7m3-jqm7)
- <https://github.com/scrapy/scrapy/security/advisories/GHSA-7j7m-v7m3-jqm7>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-3572>
- <https://github.com/scrapy/scrapy/commit/71b8741e3607cfda2833c7624d4ada87071aa8e5>
- <https://github.com/scrapy/scrapy/commit/809bfac4890f75fc73607318a04d2ccba71b3d9f>
- <https://docs.scrapy.org/en/latest/news.html#scrapy-2-11-1-2024-02-14>
- <https://github.com/scrapy/scrapy>
- <https://huntr.com/bounties/c4a0fac9-0c5a-4718-9ee4-2d06d58adabb>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7j7m-v7m3-jqm7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7j7m-v7m3-jqm7/>. Everything for agents: <https://agentprime.io/llms.txt>.
