# CodeWhale: Argument Injection in \`git_show\` Tool Allows Arbitrary File Write Without Approval

Advisory record · `GHSA-7j5w-7r7x-9v27`

- **Identifiers:** `GHSA-7j5w-7r7x-9v27` · `CVE-2026-75913`
- **State:** Confirmed
- **Severity:** CVSS 8.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-73](https://cwe.mitre.org/data/definitions/73.html) · [CWE-88](https://cwe.mitre.org/data/definitions/88.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [Command injection](https://agentprime.io/advisories/tag/command-injection.md)
- **Published:** 4 Sept 2026
- **Updated:** 4 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Sept 2026, 18:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `deepseek-tui` (crates.io): affected `>=0.3.27, <=0.8.41`; no fixed version yet
- `deepseek-tui` (npm): affected `>=0.3.27, <0.8.41`; fixed in `0.8.41`
- `codewhale-tui` (crates.io): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`
- `codewhale` (npm): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.5 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-7j5w-7r7x-9v27](https://github.com/advisories/GHSA-7j5w-7r7x-9v27)
- [OSV: GHSA-7j5w-7r7x-9v27](https://osv.dev/vulnerability/GHSA-7j5w-7r7x-9v27)
- <https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-7j5w-7r7x-9v27>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-75913>
- <https://github.com/Hmbown/CodeWhale/commit/9a34b5034d29f05d1f28fa61b04719ca6a741020>
- <https://github.com/Hmbown/CodeWhale>
- <https://www.vulncheck.com/advisories/codewhale-before-argument-injection-via-git-show>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7j5w-7r7x-9v27>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7j5w-7r7x-9v27/>. Everything for agents: <https://agentprime.io/llms.txt>.
