# Django Uses Persistent Cookies Containing Sensitive Information

Advisory record · `GHSA-7h2m-m8vj-598h`

- **Identifiers:** `GHSA-7h2m-m8vj-598h` · `BIT-django-2026-35192` · `CVE-2026-35192` · `PYSEC-2026-50`
- **State:** Confirmed
- **Severity:** CVSS 2.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-539](https://cwe.mitre.org/data/definitions/539.html)
- **Tags:** [CWE-539](https://agentprime.io/advisories/tag/cwe-539.md)
- **Published:** 5 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2026, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `django` (PyPI): affected `>=6.0, <6.0.5 || >=5.2, <5.2.14`; fixed in `6.0.5`, `5.2.14`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Django versions 5.2 before 5.2.14 and 6.0 before 6.0.5 are affected when SESSION_SAVE_EVERY_REQUEST is True. A remote attacker can steal a user's session after that user visits a cached public page. Upgrade to 5.2.14 or 6.0.5. Earlier unsupported series were not evaluated and may also be affected.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.3 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (DSF)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7h2m-m8vj-598h)

## Sources

- [GitHub Advisory Database: GHSA-7h2m-m8vj-598h](https://github.com/advisories/GHSA-7h2m-m8vj-598h)
- [OSV: GHSA-7h2m-m8vj-598h](https://osv.dev/vulnerability/GHSA-7h2m-m8vj-598h)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-35192>
- <https://docs.djangoproject.com/en/dev/releases/security>
- <https://github.com/django/django>
- <https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-50.yaml>
- <https://groups.google.com/g/django-announce>
- <https://www.djangoproject.com/weblog/2026/may/05/security-releases>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7h2m-m8vj-598h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7h2m-m8vj-598h/>. Everything for agents: <https://agentprime.io/llms.txt>.
