# phpBB has Password Reset Link Poisoning via Host Header injection

Advisory record · `GHSA-7gm6-w7mx-58cr`

- **Identifiers:** `GHSA-7gm6-w7mx-58cr` · `CVE-2026-29199` · `PKSA-k9cm-sh3f-xrxt`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-640](https://cwe.mitre.org/data/definitions/640.html)
- **Tags:** [CWE-640](https://agentprime.io/advisories/tag/cwe-640.md)
- **Published:** 4 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 May 2026, 09:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpbb/phpbb` (Packagist): affected `>=3.0.0, <3.3.16 || >=4.0.0-a1, <4.0.0-a2`; fixed in `3.3.16`, `4.0.0-a2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpBB (Packagist package phpbb/phpbb) versions from 3.0.0 before 3.3.16, and 4.0.0-a1 before 4.0.0-a2, are vulnerable to Host header injection. When force_server_vars is disabled, the server hostname can be taken from the HTTP Host header and used to build the password reset link, so an attacker who can manipulate that header (for example through a misconfigured host setup or a webserver that does not validate it) could get reset emails pointing to an attacker-controlled domain, potentially leading to account takeover. Upgrade to phpBB 3.3.16 or 4.0.0-a2, which contain fixes.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:02 UTC: First seen by agentprime
- 31 Oct 2026, 14:02 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7gm6-w7mx-58cr)

## Sources

- [GitHub Advisory Database: GHSA-7gm6-w7mx-58cr](https://github.com/advisories/GHSA-7gm6-w7mx-58cr)
- [OSV: GHSA-7gm6-w7mx-58cr](https://osv.dev/vulnerability/GHSA-7gm6-w7mx-58cr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-29199>
- <https://hackerone.com/reports/3543246>
- <https://blog.phpbb.com/2026/04/27/phpbb-4-0-0-a2-release>
- <https://github.com/phpbb/phpbb-app>
- <https://www.phpbb.com/community/viewtopic.php?t=2671024>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7gm6-w7mx-58cr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7gm6-w7mx-58cr/>. Everything for agents: <https://agentprime.io/llms.txt>.
