# Magento Violation of Secure Design Principles vulnerability in RMA PDF filename formats

Advisory record · `GHSA-7gh6-f4jh-3crq`

- **Identifiers:** `GHSA-7gh6-f4jh-3crq` · `BIT-magento-2021-28583` · `CVE-2021-28583` · `PKSA-1s1d-4jtm-mgtx` · `PKSA-n22f-w4n6-g3fx`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-657](https://cwe.mitre.org/data/definitions/657.html)
- **Tags:** [CWE-657](https://agentprime.io/advisories/tag/cwe-657.md)
- **Published:** 24 May 2022
- **Updated:** 10 Feb 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 19:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `magento/community-edition` (Packagist): affected `>=2.4.0, <2.4.2-p1 || <2.3.7`; fixed in `2.4.2-p1`, `2.3.7`
- `magento/project-community-edition` (Packagist): affected `<=2.0.2`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Magento community-edition versions before 2.3.7 and from 2.4.0 before 2.4.2-p1 are affected, as is project-community-edition at 2.0.2 and earlier. An attacker may be able to gain unauthorized access to restricted resources through a flaw in RMA PDF filename formats. Upgrade magento/community-edition to 2.3.7 or 2.4.2-p1. The source gives no fixed version for magento/project-community-edition.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (adobe)

- **CISA KEV:** Not listed.
- **EPSS:** 0.019, the 79th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:27 UTC: First seen by agentprime
- 31 Oct 2026, 14:27 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-7gh6-f4jh-3crq)

## Sources

- [GitHub Advisory Database: GHSA-7gh6-f4jh-3crq](https://github.com/advisories/GHSA-7gh6-f4jh-3crq)
- [OSV: GHSA-7gh6-f4jh-3crq](https://osv.dev/vulnerability/GHSA-7gh6-f4jh-3crq)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-28583>
- <https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695>
- <https://github.com/magento/magento2>
- <https://helpx.adobe.com/security/products/magento/apsb21-30.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7gh6-f4jh-3crq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7gh6-f4jh-3crq/>. Everything for agents: <https://agentprime.io/llms.txt>.
