# lockfile-lint-api Vulnerable to Incorrect Behavior Order

Advisory record · `GHSA-7cfr-5cjf-32p4`

- **Identifiers:** `GHSA-7cfr-5cjf-32p4` · `CVE-2025-4759`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-179](https://cwe.mitre.org/data/definitions/179.html)
- **Tags:** [CWE-179](https://agentprime.io/advisories/tag/cwe-179.md)
- **Published:** 16 May 2025
- **Updated:** 16 May 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 May 2025, 06:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `lockfile-lint-api` (npm): affected `<5.9.2`; fixed in `5.9.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L/E:P`, from CNA (snyk)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 May 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-7cfr-5cjf-32p4](https://github.com/advisories/GHSA-7cfr-5cjf-32p4)
- [OSV: GHSA-7cfr-5cjf-32p4](https://osv.dev/vulnerability/GHSA-7cfr-5cjf-32p4)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-4759>
- <https://github.com/lirantal/lockfile-lint/pull/204>
- <https://github.com/lirantal/lockfile-lint/commit/9e5305bd3e4f0c6acc0d23ec43eac2bd5303b4ca>
- <https://gist.github.com/Xavier59/881aef04940970dc3e738dcbff64151f>
- <https://github.com/lirantal/lockfile-lint>
- <https://github.com/lirantal/lockfile-lint/blob/89b5cad028df4d77bab2b73ac93bc61e392668ab/packages/lockfile-lint-api/src/validators/ValidatePackageNames.js#L51-L63>
- <https://security.snyk.io/vuln/SNYK-JS-LOCKFILELINTAPI-10169587>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7cfr-5cjf-32p4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7cfr-5cjf-32p4/>. Everything for agents: <https://agentprime.io/llms.txt>.
