# Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability

Advisory record · `GHSA-78cg-fc6c-w44w`

- **Identifiers:** `GHSA-78cg-fc6c-w44w` · `CVE-2026-33005`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-274](https://cwe.mitre.org/data/definitions/274.html)
- **Tags:** [CWE-274](https://agentprime.io/advisories/tag/cwe-274.md)
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Apr 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.openmeetings:openmeetings-parent` (Maven): affected `>=3.10, <9.0.0`; fixed in `9.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache OpenMeetings versions from 3.10 before 9.0.0 are affected. A registered user with valid credentials can query a web service to list files and sub-folders of any folder by ID, exposing metadata such as id, type and name, though not file contents. Users should upgrade to version 9.0.0, which fixes the issue.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0043, the 37th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-78cg-fc6c-w44w)

## Sources

- [GitHub Advisory Database: GHSA-78cg-fc6c-w44w](https://github.com/advisories/GHSA-78cg-fc6c-w44w)
- [OSV: GHSA-78cg-fc6c-w44w](https://osv.dev/vulnerability/GHSA-78cg-fc6c-w44w)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33005>
- <https://github.com/apache/openmeetings>
- <https://lists.apache.org/thread/pttoprd628g3xr6lpp3bm1z8m3z8t4p7>
- <https://openmeetings.apache.org/openmeetings-db/apidocs/org.apache.openmeetings.db/org/apache/openmeetings/db/dto/file/FileItemDTO.html>
- <http://www.openwall.com/lists/oss-security/2026/04/09/10>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-78cg-fc6c-w44w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-78cg-fc6c-w44w/>. Everything for agents: <https://agentprime.io/llms.txt>.
