# Active Record logging vulnerable to ANSI escape injection

Advisory record · `GHSA-76r7-hhxj-r776`

- **Identifiers:** `GHSA-76r7-hhxj-r776` · `CVE-2025-55193`
- **State:** Confirmed
- **Severity:** CVSS 2.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 13 Aug 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Aug 2025, 22:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `activerecord` (RubyGems): affected `>=8.0, <8.0.2.1 || >=7.2, <7.2.2.2 || <7.1.5.2`; fixed in `8.0.2.1`, `7.2.2.2`, `7.1.5.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.7 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:U`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-76r7-hhxj-r776)

## Sources

- [GitHub Advisory Database: GHSA-76r7-hhxj-r776](https://github.com/advisories/GHSA-76r7-hhxj-r776)
- [OSV: GHSA-76r7-hhxj-r776](https://osv.dev/vulnerability/GHSA-76r7-hhxj-r776)
- <https://github.com/rails/rails/security/advisories/GHSA-76r7-hhxj-r776>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-55193>
- <https://github.com/rails/rails/commit/3beef20013736fd52c5dcfdf061f7999ba318290>
- <https://github.com/rails/rails/commit/568c0bc2f1e74c65d150a84b89a080949bf9eb9b>
- <https://github.com/rails/rails/commit/6a944ca4805e72050a0fbb1a461534eb760d3202>
- <https://github.com/rails/rails>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2025-55193.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-76r7-hhxj-r776>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-76r7-hhxj-r776/>. Everything for agents: <https://agentprime.io/llms.txt>.
