# on-headers is vulnerable to http response header manipulation

Advisory record · `GHSA-76c9-3jph-rj3q`

- **Identifiers:** `GHSA-76c9-3jph-rj3q` · `CVE-2025-7339`
- **State:** Confirmed
- **Severity:** CVSS 3.4 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-241](https://cwe.mitre.org/data/definitions/241.html)
- **Tags:** [CWE-241](https://agentprime.io/advisories/tag/cwe-241.md)
- **Published:** 17 Jul 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Jul 2025, 21:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `on-headers` (npm): affected `<1.1.0`; fixed in `1.1.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.4 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0021, the 10th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 17 Jul 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-76c9-3jph-rj3q](https://github.com/advisories/GHSA-76c9-3jph-rj3q)
- [OSV: GHSA-76c9-3jph-rj3q](https://osv.dev/vulnerability/GHSA-76c9-3jph-rj3q)
- <https://github.com/jshttp/on-headers/security/advisories/GHSA-76c9-3jph-rj3q>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-7339>
- <https://github.com/expressjs/morgan/issues/315>
- <https://github.com/jshttp/on-headers/issues/15>
- <https://github.com/jshttp/on-headers/commit/c6e384908c9c6127d18831d16ab0bd96e1231867>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/jshttp/on-headers>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-76c9-3jph-rj3q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-76c9-3jph-rj3q/>. Everything for agents: <https://agentprime.io/llms.txt>.
