# Avo has a XSS vulnerability on \`return_to\` param

Advisory record · `GHSA-762r-27w2-q22j`

- **Identifiers:** `GHSA-762r-27w2-q22j` · `CVE-2026-33209`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 18 Mar 2026
- **Updated:** 25 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Mar 2026, 17:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `avo` (RubyGems): affected `<3.30.3`; fixed in `3.30.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0027, the 19th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-762r-27w2-q22j](https://github.com/advisories/GHSA-762r-27w2-q22j)
- [OSV: GHSA-762r-27w2-q22j](https://osv.dev/vulnerability/GHSA-762r-27w2-q22j)
- <https://github.com/avo-hq/avo/security/advisories/GHSA-762r-27w2-q22j>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33209>
- <https://github.com/avo-hq/avo/pull/4330>
- <https://github.com/avo-hq/avo/commit/4453d39ddc6309f3bc8ada73ef21e1971112de7d>
- <https://github.com/avo-hq/avo>
- <https://github.com/avo-hq/avo/releases/tag/v3.30.3>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/avo/CVE-2026-33209.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-762r-27w2-q22j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-762r-27w2-q22j/>. Everything for agents: <https://agentprime.io/llms.txt>.
