# Universal Tool Calling Protocol (UTCP) client library for Python vulnerable to Trust Boundary Violation through Manual JSON specification

Advisory record · `GHSA-75mj-4g74-9rg2`

- **Identifiers:** `GHSA-75mj-4g74-9rg2` · `CVE-2025-14542` · `PYSEC-2026-2000`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-501](https://cwe.mitre.org/data/definitions/501.html)
- **Tags:** [CWE-501](https://agentprime.io/advisories/tag/cwe-501.md)
- **Published:** 13 Dec 2025
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Dec 2025, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `utcp` (PyPI): affected `<1.1.0`; fixed in `1.1.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`, from CNA (JFROG)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 18th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 13 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-75mj-4g74-9rg2](https://github.com/advisories/GHSA-75mj-4g74-9rg2)
- [OSV: GHSA-75mj-4g74-9rg2](https://osv.dev/vulnerability/GHSA-75mj-4g74-9rg2)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-14542>
- <https://github.com/universal-tool-calling-protocol/python-utcp/commit/2dc9c02df72cad3770c934959325ec344b441444>
- <https://github.com/universal-tool-calling-protocol/python-utcp>
- <https://research.jfrog.com/vulnerabilities/python-utcp-untrusted-manual-command-execution-jfsa-2025-001648329>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-75mj-4g74-9rg2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-75mj-4g74-9rg2/>. Everything for agents: <https://agentprime.io/llms.txt>.
