# A vulnerability in mlflow/mlflow versions 3.9.0 and earlier allows unauthenticated access to certain FastAPI routes when the server is started with authentication enabled (\`--app-name basic-auth\`) ...

Advisory record · `GHSA-75cm-x2w3-8mgf`

- **Identifiers:** `GHSA-75cm-x2w3-8mgf` · `BIT-mlflow-2026-2652` · `CVE-2026-2652` · `PYSEC-2026-2221`
- **State:** Confirmed
- **Severity:** CVSS 8.6 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-305](https://cwe.mitre.org/data/definitions/305.html)
- **Tags:** [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 15 May 2026
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 May 2026, 03:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 8.6 (7.0 or more) and EPSS 0.21 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `mlflow` (PyPI): affected `<3.10.0`; fixed in `3.10.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mlflow versions before 3.10.0 are affected when the server runs with basic authentication enabled under uvicorn (ASGI). The FastAPI permission middleware only checks authentication on /gateway/ routes, so routes such as the Job API and trace ingestion API accept requests without credentials. A remote unauthenticated attacker could submit, read, and cancel jobs and inject trace data into experiments. Upgrade to mlflow 3.10.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.6 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.21, the 97th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:43 UTC: First seen by agentprime
- 31 Oct 2026, 14:43 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-2221)

## Sources

- [GitHub Advisory Database: GHSA-75cm-x2w3-8mgf](https://github.com/advisories/GHSA-75cm-x2w3-8mgf)
- [OSV: GHSA-75cm-x2w3-8mgf](https://osv.dev/vulnerability/GHSA-75cm-x2w3-8mgf)
- <https://github.com/mlflow/mlflow/commit/bb62e773263c14e9ba4d1a82fe72d0de2442c6aa>
- <https://github.com/advisories/GHSA-75cm-x2w3-8mgf>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-75cm-x2w3-8mgf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-75cm-x2w3-8mgf/>. Everything for agents: <https://agentprime.io/llms.txt>.
