# Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') in tornado

Advisory record · `GHSA-753j-mpmx-qq6g`

- **Identifiers:** `GHSA-753j-mpmx-qq6g` · `CVE-2024-14029`
- **State:** Confirmed
- **Severity:** CVSS 9.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 6 Jun 2024
- **Updated:** 16 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jun 2024, 21:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `tornado` (PyPI): affected `<6.4.1`; fixed in `6.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Tornado versions before 6.4.1 ignore requests that contain two Transfer-Encoding: chunked headers, so they are treated as having no body. An attacker who can send requests through a proxy that forwards such headers can smuggle requests, which may allow ACL bypass, cache poisoning, or connection desynchronization. Upgrade tornado to version 6.4.1 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.0 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 30th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:10 UTC: First seen by agentprime
- 31 Oct 2026, 14:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-753j-mpmx-qq6g)

## Sources

- [GitHub Advisory Database: GHSA-753j-mpmx-qq6g](https://github.com/advisories/GHSA-753j-mpmx-qq6g)
- [OSV: GHSA-753j-mpmx-qq6g](https://osv.dev/vulnerability/GHSA-753j-mpmx-qq6g)
- <https://github.com/tornadoweb/tornado/security/advisories/GHSA-753j-mpmx-qq6g>
- <https://github.com/tornadoweb/tornado/commit/d65f6e71a77f53a1ff0a0dc55704be13f04eb572>
- <https://github.com/tornadoweb/tornado>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-753j-mpmx-qq6g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-753j-mpmx-qq6g/>. Everything for agents: <https://agentprime.io/llms.txt>.
