# Incorrect header handling in mod-wsgi

Advisory record · `GHSA-7527-8855-9cf8`

- **Identifiers:** `GHSA-7527-8855-9cf8` · `BIT-mod_wsgi-2022-2255` · `CVE-2022-2255` · `PYSEC-2022-254`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-345](https://cwe.mitre.org/data/definitions/345.html) · [CWE-348](https://cwe.mitre.org/data/definitions/348.html)
- **Tags:** [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md) · [CWE-348](https://agentprime.io/advisories/tag/cwe-348.md)
- **Published:** 26 Aug 2022
- **Updated:** 25 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Aug 2022, 00:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mod-wsgi` (PyPI): affected `<4.9.3`; fixed in `4.9.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0094, the 61st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 26 Aug 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-7527-8855-9cf8](https://github.com/advisories/GHSA-7527-8855-9cf8)
- [OSV: GHSA-7527-8855-9cf8](https://osv.dev/vulnerability/GHSA-7527-8855-9cf8)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-2255>
- <https://github.com/GrahamDumpleton/mod_wsgi/commit/af3c0c2736bc0b0b01fa0f0aad3c904b7fa9c751>
- <https://github.com/GrahamDumpleton/mod_wsgi>
- <https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L13940-L13941>
- <https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L14046-L14082>
- <https://github.com/pypa/advisory-database/tree/main/vulns/mod-wsgi/PYSEC-2022-254.yaml>
- <https://lists.debian.org/debian-lts-announce/2022/09/msg00021.html>
- <https://modwsgi.readthedocs.io/en/latest/release-notes/version-4.9.3.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-7527-8855-9cf8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-7527-8855-9cf8/>. Everything for agents: <https://agentprime.io/llms.txt>.
