# Devise Gem for Ruby Unauthorized Access Using "Remember Me" Cookie

Advisory record · `GHSA-746g-3gfp-hfhw`

- **Identifiers:** `GHSA-746g-3gfp-hfhw` · `CVE-2015-8314`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-288](https://cwe.mitre.org/data/definitions/288.html) · [CWE-312](https://cwe.mitre.org/data/definitions/312.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md)
- **Published:** 26 Jan 2023
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Jan 2023, 23:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `devise` (RubyGems): affected `<3.5.4`; fixed in `3.5.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 26 Jan 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-746g-3gfp-hfhw](https://github.com/advisories/GHSA-746g-3gfp-hfhw)
- [OSV: GHSA-746g-3gfp-hfhw](https://osv.dev/vulnerability/GHSA-746g-3gfp-hfhw)
- <https://nvd.nist.gov/vuln/detail/CVE-2015-8314>
- <https://github.com/heartcombo/devise/commit/c92996646aba2d25b2c3e235fe0c4f1a84b70d24>
- <https://github.com/advisories/GHSA-746g-3gfp-hfhw>
- <https://github.com/heartcombo/devise>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/devise/CVE-2015-8314.yml>
- <https://rubysec.com/advisories/CVE-2015-8314>
- <http://blog.plataformatec.com.br/2016/01/improve-remember-me-cookie-expiration-in-devise>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-746g-3gfp-hfhw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-746g-3gfp-hfhw/>. Everything for agents: <https://agentprime.io/llms.txt>.
