# protobuf-java has potential Denial of Service issue

Advisory record · `GHSA-735f-pc8j-v9w8`

- **Identifiers:** `GHSA-735f-pc8j-v9w8` · `CVE-2024-7254`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-674](https://cwe.mitre.org/data/definitions/674.html) · [CWE-787](https://cwe.mitre.org/data/definitions/787.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 19 Sept 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Sept 2024, 16:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.google.protobuf:protobuf-java` (Maven): affected `<3.25.5 || >=4.0.0-RC1, <4.27.5 || >=4.28.0-RC1, <4.28.2`; fixed in `3.25.5`, `4.27.5`, `4.28.2`
- `com.google.protobuf:protobuf-javalite` (Maven): affected `<3.25.5 || >=4.0.0-RC1, <4.27.5 || >=4.28.0-RC1, <4.28.2`; fixed in `3.25.5`, `4.27.5`, `4.28.2`
- `com.google.protobuf:protobuf-kotlin` (Maven): affected `<3.25.5 || >=4.0.0-RC1, <4.27.5 || >=4.28.0-RC1, <4.28.2`; fixed in `3.25.5`, `4.27.5`, `4.28.2`
- `com.google.protobuf:protobuf-kotlin-lite` (Maven): affected `<3.25.5 || >=4.0.0-RC1, <4.27.5 || >=4.28.0-RC1, <4.28.2`; fixed in `3.25.5`, `4.27.5`, `4.28.2`
- `google-protobuf` (RubyGems): affected `<3.25.5 || >=4.0.0.rc.1, <4.27.5 || >=4.28.0.rc.1, <4.28.2`; fixed in `3.25.5`, `4.27.5`, `4.28.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The protobuf-java, protobuf-javalite, protobuf-kotlin and protobuf-kotlin-lite Maven packages, and the google-protobuf RubyGems package, are affected in versions before 3.25.5, from 4.0.0-RC1 up to 4.27.5, and from 4.28.0-RC1 up to 4.28.2. An attacker who can supply a maliciously crafted message to a parser can trigger unbounded recursion while parsing nested groups as unknown fields or map fields, causing a StackOverflow error and crashing the program. Upgrade to 3.25.5, 4.27.5, or 4.28.2, depending on your release line.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (Google)

- **CISA KEV:** Not listed.
- **EPSS:** 0.028, the 86th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-735f-pc8j-v9w8)

## Sources

- [GitHub Advisory Database: GHSA-735f-pc8j-v9w8](https://github.com/advisories/GHSA-735f-pc8j-v9w8)
- [OSV: GHSA-735f-pc8j-v9w8](https://osv.dev/vulnerability/GHSA-735f-pc8j-v9w8)
- <https://github.com/protocolbuffers/protobuf/security/advisories/GHSA-735f-pc8j-v9w8>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-7254>
- <https://github.com/protocolbuffers/protobuf/commit/4728531c162f2f9e8c2ca1add713cfee2db6be3b>
- <https://github.com/protocolbuffers/protobuf/commit/850fcce9176e2c9070614dab53537760498c926b>
- <https://github.com/protocolbuffers/protobuf/commit/9a5f5fe752a20cbac2e722b06949ac985abdd534>
- <https://github.com/protocolbuffers/protobuf/commit/ac9fb5b4c71b0dd80985b27684e265d1f03abf46>
- <https://github.com/protocolbuffers/protobuf/commit/cc8b3483a5584b3301e3d43d17eb59704857ffaa>
- <https://github.com/protocolbuffers/protobuf/commit/d6c82fc55a76481c676f541a255571e8950bb8c3>
- <https://github.com/protocolbuffers/protobuf>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/google-protobuf/CVE-2024-7254.yml>
- <https://security.netapp.com/advisory/ntap-20241213-0010>
- <https://security.netapp.com/advisory/ntap-20250418-0006>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-735f-pc8j-v9w8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-735f-pc8j-v9w8/>. Everything for agents: <https://agentprime.io/llms.txt>.
