# Strapi allows unauthenticated attacker to reset admin password without valid reset token

Advisory record · `GHSA-6xc2-mj39-q599`

- **Identifiers:** `GHSA-6xc2-mj39-q599` · `CVE-2019-18818`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-640](https://cwe.mitre.org/data/definitions/640.html)
- **Tags:** [CWE-640](https://agentprime.io/advisories/tag/cwe-640.md)
- **Published:** 2 Dec 2019
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Dec 2019, 18:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.
- CVSS score 9.8 (7.0 or more) and EPSS 0.97 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `strapi` (npm): affected `<3.0.0-beta.17.5`; fixed in `3.0.0-beta.17.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.97, the 99th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 2 Dec 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-6xc2-mj39-q599](https://github.com/advisories/GHSA-6xc2-mj39-q599)
- [OSV: GHSA-6xc2-mj39-q599](https://osv.dev/vulnerability/GHSA-6xc2-mj39-q599)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-18818>
- <https://github.com/strapi/strapi/pull/4443>
- <https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18818>
- <https://github.com/strapi/strapi>
- <https://github.com/strapi/strapi/releases/tag/v3.0.0-beta.17.5>
- <https://www.npmjs.com/advisories/1311>
- <http://packetstormsecurity.com/files/163939/Strapi-3.0.0-beta-Authentication-Bypass.html>
- <http://packetstormsecurity.com/files/163950/Strapi-CMS-3.0.0-beta.17.4-Remote-Code-Execution.html>
- <http://packetstormsecurity.com/files/165896/Strapi-CMS-3.0.0-beta.17.4-Privilege-Escalation.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6xc2-mj39-q599>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6xc2-mj39-q599/>. Everything for agents: <https://agentprime.io/llms.txt>.
