# LightRAG: CORS Wildcard + Credentials Enables Any-Origin Credentialed Requests

Advisory record · `GHSA-6x6h-qqr7-855w`

- **Identifiers:** `GHSA-6x6h-qqr7-855w` · `CVE-2026-61736` · `PYSEC-2026-3474`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-942](https://cwe.mitre.org/data/definitions/942.html)
- **Tags:** [CWE-942](https://agentprime.io/advisories/tag/cwe-942.md)
- **Published:** 20 Jul 2026
- **Updated:** 23 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Jul 2026, 21:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `lightrag-hku` (PyPI): affected `<1.5.4`; fixed in `1.5.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> LightRAG versions before 1.5.4 default to a CORS setting of wildcard origins combined with credentials allowed, so the server echoes any requesting origin for credentialed cross-origin requests. A malicious website visited by a logged-in LightRAG user can make authenticated API calls, potentially reading documents and knowledge graph data or deleting the document store. Upgrade to lightrag-hku 1.5.4 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.014, the 72nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:41 UTC: First seen by agentprime
- 31 Oct 2026, 14:41 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6x6h-qqr7-855w)

## Sources

- [GitHub Advisory Database: GHSA-6x6h-qqr7-855w](https://github.com/advisories/GHSA-6x6h-qqr7-855w)
- [OSV: GHSA-6x6h-qqr7-855w](https://osv.dev/vulnerability/GHSA-6x6h-qqr7-855w)
- <https://github.com/HKUDS/LightRAG/security/advisories/GHSA-6x6h-qqr7-855w>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-61736>
- <https://github.com/HKUDS/LightRAG/pull/3317>
- <https://github.com/HKUDS/LightRAG/commit/09567a4c983f580050db63569dd477122c058c3d>
- <https://github.com/HKUDS/LightRAG/commit/df68d75f9dc29dd340ffb6794b48f48c4fdc9a2d>
- <https://github.com/HKUDS/LightRAG/commit/ebba6548639c0f2e8919100eff76b401f1222252>
- <https://github.com/HKUDS/LightRAG>
- <https://github.com/HKUDS/LightRAG/releases/tag/v1.5.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6x6h-qqr7-855w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6x6h-qqr7-855w/>. Everything for agents: <https://agentprime.io/llms.txt>.
