# vm2 allows a sandboxed plugin to execute native code through \`node:sqlite\`

Advisory record · `GHSA-6w8r-xxw2-g3hx`

- **Identifiers:** `GHSA-6w8r-xxw2-g3hx` · `CVE-2026-92938`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-693](https://cwe.mitre.org/data/definitions/693.html)
- **Tags:** [CWE-693](https://agentprime.io/advisories/tag/cwe-693.md)
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Oct 2026, 15:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `vm2` (npm): affected `>=3.11.3, <3.11.7`; fixed in `3.11.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vm2 versions 3.11.3 up to but not including 3.11.7 expose the node:sqlite module to NodeVM code when that builtin is allowed explicitly or through the wildcard builtin setting. An untrusted plugin running in the sandbox can load a native library bundled in its own package, which runs native code in the host Node.js process outside the sandbox. Upgrade to vm2 3.11.7, the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6w8r-xxw2-g3hx)

## Sources

- [GitHub Advisory Database: GHSA-6w8r-xxw2-g3hx](https://github.com/advisories/GHSA-6w8r-xxw2-g3hx)
- [OSV: GHSA-6w8r-xxw2-g3hx](https://osv.dev/vulnerability/GHSA-6w8r-xxw2-g3hx)
- <https://github.com/patriksimek/vm2/security/advisories/GHSA-6w8r-xxw2-g3hx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-92938>
- <https://github.com/patriksimek/vm2/commit/aa146a77f859325e079f3bfbfe6d8309af483daa>
- <https://github.com/patriksimek/vm2>
- <https://github.com/patriksimek/vm2/releases/tag/v3.11.7>
- <https://www.vulncheck.com/advisories/vm2-3.11.3-through-3.11.6-remote-code-execution-via-node-sqlite>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6w8r-xxw2-g3hx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6w8r-xxw2-g3hx/>. Everything for agents: <https://agentprime.io/llms.txt>.
