# Buffer overflow in sponge queue functions

Advisory record · `GHSA-6w4m-2xhg-2658`

- **Identifiers:** `GHSA-6w4m-2xhg-2658` · `BIT-libphp-2022-37454` · `BIT-libpython-2022-37454` · `BIT-php-2022-37454` · `BIT-php-min-2022-37454` · `BIT-python-2022-37454` · `BIT-python-min-2022-37454` · `CVE-2022-37454` · `PSF-2022-11` · `PYSEC-2026-504`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-190](https://cwe.mitre.org/data/definitions/190.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 26 Apr 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Apr 2023, 17:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `pysha3` (PyPI): affected `<=1.0.2`; no fixed version yet
- `sha3` (RubyGems): affected `<1.0.5`; fixed in `1.0.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.074, the 94th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:37 UTC: First seen by agentprime
- 31 Oct 2026, 14:37 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6w4m-2xhg-2658)

## Sources

- [GitHub Advisory Database: GHSA-6w4m-2xhg-2658](https://github.com/advisories/GHSA-6w4m-2xhg-2658)
- [OSV: GHSA-6w4m-2xhg-2658](https://osv.dev/vulnerability/GHSA-6w4m-2xhg-2658)
- <https://github.com/XKCP/XKCP/security/advisories/GHSA-6w4m-2xhg-2658>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-37454>
- <https://github.com/XKCP/XKCP/issues/105>
- <https://github.com/johanns/sha3/issues/17>
- <https://github.com/tiran/pysha3/issues/29>
- <https://github.com/XKCP/XKCP/commit/fdc6fef075f4e81d6b1bc38364248975e08e340a>
- <https://github.com/johanns/sha3/commit/5f2e8118a62831911703c8753ff2435c3b5d7312>
- <https://www.debian.org/security/2022/dsa-5269>
- <https://www.debian.org/security/2022/dsa-5267>
- <https://security.gentoo.org/glsa/202305-02>
- <https://news.ycombinator.com/item?id=35050307>
- <https://news.ycombinator.com/item?id=33281106>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6w4m-2xhg-2658>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6w4m-2xhg-2658/>. Everything for agents: <https://agentprime.io/llms.txt>.
