# Language Servers for AWS vulnerable to arbitrary file write

Advisory record · `GHSA-6v3r-4p5c-mrp5`

- **Identifiers:** `GHSA-6v3r-4p5c-mrp5` · `CVE-2026-12958`
- **State:** Confirmed
- **Severity:** CVSS 8.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-61](https://cwe.mitre.org/data/definitions/61.html)
- **Tags:** [CWE-61](https://agentprime.io/advisories/tag/cwe-61.md)
- **Published:** 24 Sept 2026
- **Updated:** 24 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Sept 2026, 19:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@aws/lsp-codewhisperer` (npm): affected `<0.0.117`; fixed in `0.0.117`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.5 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (AMZN)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 8th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-6v3r-4p5c-mrp5](https://github.com/advisories/GHSA-6v3r-4p5c-mrp5)
- [OSV: GHSA-6v3r-4p5c-mrp5](https://osv.dev/vulnerability/GHSA-6v3r-4p5c-mrp5)
- <https://github.com/aws/language-servers/security/advisories/GHSA-6v3r-4p5c-mrp5>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-12958>
- <https://github.com/Amazon-Q-Developer/language-servers/pull/2742>
- <https://github.com/Amazon-Q-Developer/language-servers/commit/6c279b083cc192aa5df1f38c2c185576fd5234f5>
- <https://aws.amazon.com/security/security-bulletins/2026-047-aws>
- <https://github.com/Amazon-Q-Developer/language-servers/releases/tag/agentic-rc-1.69.0>
- <https://github.com/Amazon-Q-Developer/language-servers/releases/tag/lsp-codewhisperer/v0.0.117>
- <https://github.com/aws/language-servers>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6v3r-4p5c-mrp5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6v3r-4p5c-mrp5/>. Everything for agents: <https://agentprime.io/llms.txt>.
