# Spring REST Docs REST Assured & WebFlux are vulnerable to Improper Restriction of XML External Entity Reference

Advisory record · `GHSA-6rpq-6vv2-5222`

- **Identifiers:** `GHSA-6rpq-6vv2-5222` · `CVE-2026-40991`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 10 Jun 2026
- **Updated:** 12 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Jun 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.springframework.restdocs:spring-restdocs-webtestclient` (Maven): affected `>=4.0.0, <4.0.1 || >=3.0.0, <3.0.6 || <=2.0.8.RELEASE`; fixed in `4.0.1`, `3.0.6`
- `org.springframework.restdocs:spring-restdocs-restassured` (Maven): affected `>=4.0.0, <4.0.1 || >=3.0.0, <3.0.6 || <=2.0.8.RELEASE`; fixed in `4.0.1`, `3.0.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Spring REST Docs' spring-restdocs-webtestclient and spring-restdocs-restassured packages are affected in versions 4.0.0, 3.0.0 through 3.0.5, and 2.0.0.RELEASE through 2.0.8.RELEASE. An attacker who compromises a remote API, or tricks a user into documenting a malicious API, can perform an XML external entity (XXE) injection when the documentation-generating tests next run. Upgrade to spring-restdocs-webtestclient or spring-restdocs-restassured 4.0.1 or 3.0.6.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:L`, from CNA (vmware)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6rpq-6vv2-5222)

## Sources

- [GitHub Advisory Database: GHSA-6rpq-6vv2-5222](https://github.com/advisories/GHSA-6rpq-6vv2-5222)
- [OSV: GHSA-6rpq-6vv2-5222](https://osv.dev/vulnerability/GHSA-6rpq-6vv2-5222)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40991>
- <https://github.com/spring-projects/spring-restdocs>
- <https://github.com/spring-projects/spring-restdocs/releases/tag/v3.0.6>
- <https://github.com/spring-projects/spring-restdocs/releases/tag/v4.0.1>
- <https://spring.io/security/cve-2026-40991>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6rpq-6vv2-5222>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6rpq-6vv2-5222/>. Everything for agents: <https://agentprime.io/llms.txt>.
